BETA

10th March 2021

West Bengal Issue observed for 'Outgoing Calls' in West Bengal Region

Identified at [10/03/21 01:25 PM] with 'Partial Outage'

Issue has been resolved at [10/03/21 01:35 PM]