BETA

29th June 2017

West Bengal Issue observed for 'Outgoing Calls' in West Bengal Region

Identified at [29/06/17 05:43 AM] with 'Major Outage'

Issue has been resolved at [29/06/17 05:46 AM]