BETA

17th March 2019

Delhi Issue observed for 'Outgoing Calls' in Delhi Region

Identified at [17/03/19 05:25 AM] with 'Partial Outage'

Issue has been resolved at [17/03/19 05:26 AM]