Exotel Status Board
Home
Dashboard
BETA
28th February 2021
Delhi
Issue observed for 'Outgoing Calls' in Delhi Region
Identified at [28/02/21 02:49 AM] with 'Major Outage'
Issue has been resolved at [28/02/21 03:00 AM]