BETA

26th February 2021

Delhi Issue observed for 'Outgoing Calls' in Delhi Region

Identified at [26/02/21 03:35 AM] with 'Partial Outage'

Issue has been resolved at [26/02/21 03:44 AM]