BETA

29th June 2017

Mumbai Issue observed for 'Outgoing Calls' in Mumbai Region

Identified at [29/06/17 05:30 AM] with 'Partial Outage'

Issue has been resolved at [29/06/17 05:32 AM]