BETA

27th January 2021

West Bengal Issue observed for 'Outgoing Calls' in West Bengal Region

Identified at [27/01/21 04:09 PM] with 'Major Outage'

Issue has been resolved at [27/01/21 04:19 PM]