BETA

29th June 2017

Karnataka Issue observed for 'Outgoing Calls' in Karnataka Region

Identified at [29/06/17 05:23 AM] with 'Partial Outage'

Issue has been resolved at [29/06/17 05:26 AM]