BETA

7th August 2016

Delhi Issue observed for 'Outgoing Calls' in Delhi Region

Identified at [07/08/16 12:44 AM] with 'Major Outage'

Issue has been resolved at [07/08/16 12:46 AM]